summaryrefslogtreecommitdiffstats
path: root/src/compiler/glsl/meson.build
diff options
context:
space:
mode:
authorAlejandro Piñeiro <[email protected]>2018-03-28 14:59:26 +0200
committerAlejandro Piñeiro <[email protected]>2018-06-21 14:25:05 +0200
commitaa95f0bc5b05fdab4e258d02c1a69abd8317920e (patch)
treee85e93b3983eb68e032bd5532b1488fac354d502 /src/compiler/glsl/meson.build
parentb995bda9bca0d368f1433b153b64e5200d39bc1d (diff)
compiler/link: add linker_util.h, move linker_error/warning to it
Linker utilities common to the GLSL IR and NIR linker (the latter to be used for ARB_gl_spirv). We need to move it to a new header as the NIR linker doesn't need to know about ir_variable, and others, included at linker.h. v2: move from src/compiler to src/compiler/glsl (Timothy Arceri) Reviewed-by: Timothy Arceri <[email protected]>
Diffstat (limited to 'src/compiler/glsl/meson.build')
-rw-r--r--src/compiler/glsl/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/glsl/meson.build b/src/compiler/glsl/meson.build
index 055a84714c1..686a5a4ac0b 100644
--- a/src/compiler/glsl/meson.build
+++ b/src/compiler/glsl/meson.build
@@ -112,6 +112,7 @@ files_libglsl = files(
'ir_visitor.h',
'linker.cpp',
'linker.h',
+ 'linker_util.h',
'link_atomics.cpp',
'link_functions.cpp',
'link_interface_blocks.cpp',