aboutsummaryrefslogtreecommitdiffstats
path: root/src/compiler/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-08-16 13:59:38 +0100
committerEmil Velikov <[email protected]>2018-08-23 17:00:13 +0100
commitae7898dfdbe5c8dab7d11c71862353f1ae43feb0 (patch)
treedf2e6bbf52a4a9450f1306bf8344b049eb1fb71e /src/compiler/Makefile.am
parentc51e7486d90a605b18109d5509fed0d3db23a8a5 (diff)
configure: allow building with python3
Pretty much all of the scripts are python2+3 compatible. Check and allow using python3, while adjusting the PYTHON2 refs. Note: - python3.4 is used as it's the earliest supported version - python3 chosen prior to python2 Signed-off-by: Emil Velikov <[email protected]> Acked-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/compiler/Makefile.am')
-rw-r--r--src/compiler/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/compiler/Makefile.am b/src/compiler/Makefile.am
index 73435a3b5d6..05cdb1446c0 100644
--- a/src/compiler/Makefile.am
+++ b/src/compiler/Makefile.am
@@ -68,7 +68,7 @@ EXTRA_DIST = \
meson.build
MKDIR_GEN = $(AM_V_at)$(MKDIR_P) $(@D)
-PYTHON_GEN = $(AM_V_GEN)$(PYTHON2) $(PYTHON_FLAGS)
+PYTHON_GEN = $(AM_V_GEN)$(PYTHON) $(PYTHON_FLAGS)
include Makefile.spirv.am