aboutsummaryrefslogtreecommitdiffstats
path: root/src/compiler/Makefile.am
diff options
context:
space:
mode:
authorNicolai Hähnle <[email protected]>2017-06-24 10:26:29 +0200
committerNicolai Hähnle <[email protected]>2017-07-05 12:26:10 +0200
commit3628efedf29d2b5e181ea88f24db518038ab1a92 (patch)
treeeb49d9cc4edf8b5aff0212bb73184f1d1f3cd50b /src/compiler/Makefile.am
parent210ebd4b9c1b510ff1b29a81aa7512ea77056966 (diff)
glsl/blob: add valgrind checks that written data is defined
Undefined data will eventually trigger a valgrind error while computing its CRC32 while writing it into the disk cache, but at that point, it is basically impossible to track down where the undefined data came from. With this change, finding the origin of undefined data becomes easy. v2: remove duplicate VALGRIND_CFLAGS (Emil) Reviewed-by: Timothy Arceri <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/compiler/Makefile.am')
-rw-r--r--src/compiler/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/Makefile.am b/src/compiler/Makefile.am
index d52da91dab8..4c83365094b 100644
--- a/src/compiler/Makefile.am
+++ b/src/compiler/Makefile.am
@@ -36,6 +36,7 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/src/gallium/include \
-I$(top_srcdir)/src/gallium/auxiliary \
-I$(top_srcdir)/src/gtest/include \
+ $(VALGRIND_CFLAGS) \
$(DEFINES)
AM_CFLAGS = \