summaryrefslogtreecommitdiffstats
path: root/src/compiler/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2017-08-14 10:40:09 -0700
committerIan Romanick <[email protected]>2018-03-29 14:16:01 -0700
commit042ee4bea26272bd7c358cc9541e576a8352890c (patch)
treed03707e886103019722ee20ba86cdf57c67b7097 /src/compiler/Makefile.am
parent2c9621ee5c5fa40be071858f99fb256fc37369b4 (diff)
spirv: Move SPIR-V building to Makefile.spirv.am and spirv/meson.build
Future changes will add generated files used only from src/compiler/glsl. These can't be built from Makefile.nir.am, and we can't move all the rules from Makefile.nir.am to Makefile.spirv.am (and it would be silly anyway). v2: Do it for meson too. Signed-off-by: Ian Romanick <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> (the meson bits) Reviewed-by: Alejandro PiƱeiro <[email protected]> (the automake bits)
Diffstat (limited to 'src/compiler/Makefile.am')
-rw-r--r--src/compiler/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/compiler/Makefile.am b/src/compiler/Makefile.am
index 18c062019f0..8ec9b0449ca 100644
--- a/src/compiler/Makefile.am
+++ b/src/compiler/Makefile.am
@@ -69,6 +69,8 @@ EXTRA_DIST = \
MKDIR_GEN = $(AM_V_at)$(MKDIR_P) $(@D)
PYTHON_GEN = $(AM_V_GEN)$(PYTHON2) $(PYTHON_FLAGS)
+include Makefile.spirv.am
+
include Makefile.glsl.am
include Makefile.nir.am