summaryrefslogtreecommitdiffstats
path: root/src/broadcom/compiler/meson.build
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2019-02-26 10:17:59 -0800
committerEric Anholt <[email protected]>2019-03-05 12:57:39 -0800
commit110f14d4b4bdee779a35c26e3224a9d28eb81fa7 (patch)
treea5da34b8b3372a22d30535d15772c0d188008dab /src/broadcom/compiler/meson.build
parent4036fce8fd75277567894afc595e16a4742d4587 (diff)
v3d: Use ldunif instructions for uniforms.
The idea is that for repeated use of the same uniform, we could avoid loading it on each consumer. The results look pretty good. total instructions in shared programs: 6413571 -> 6521464 (1.68%) total threads in shared programs: 154214 -> 154000 (-0.14%) total uniforms in shared programs: 2393604 -> 2119629 (-11.45%) total spills in shared programs: 4960 -> 4984 (0.48%) total fills in shared programs: 6350 -> 6418 (1.07%) Once we do scheduling at the NIR level, the register pressure (and thus also instructions) issues we see here will drop back down.
Diffstat (limited to 'src/broadcom/compiler/meson.build')
-rw-r--r--src/broadcom/compiler/meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/broadcom/compiler/meson.build b/src/broadcom/compiler/meson.build
index c80918db30f..af800b34c28 100644
--- a/src/broadcom/compiler/meson.build
+++ b/src/broadcom/compiler/meson.build
@@ -23,7 +23,6 @@ libbroadcom_compiler_files = files(
'vir.c',
'vir_dump.c',
'vir_live_variables.c',
- 'vir_lower_uniforms.c',
'vir_opt_copy_propagate.c',
'vir_opt_dead_code.c',
'vir_opt_small_immediates.c',