aboutsummaryrefslogtreecommitdiffstats
path: root/src/amd/vulkan/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-12-11 15:56:08 -0800
committerDylan Baker <[email protected]>2018-01-11 15:40:02 -0800
commitfbf192a67ed2e3d4f614b49fe008c980c5f7c9a2 (patch)
treed0320f703e9b2ffc4096720db4784cf10ea882ef /src/amd/vulkan/meson.build
parentc3d802d68e222bf4030ab4e487501dfbcb34608d (diff)
meson: Use consistent style
Currently the meosn build has a mix of two styles: arg : [foo, ... bar], and arg : [ foo, ..., bar, ] For consistency let's pick one. I've picked the later style, which I think is more readable, and is more common in the mesa code base. v2: - fix commit message Acked-by: Eric Engestrom <[email protected]> Signed-off-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/amd/vulkan/meson.build')
-rw-r--r--src/amd/vulkan/meson.build32
1 files changed, 21 insertions, 11 deletions
diff --git a/src/amd/vulkan/meson.build b/src/amd/vulkan/meson.build
index 93997350a25..054ee5e282b 100644
--- a/src/amd/vulkan/meson.build
+++ b/src/amd/vulkan/meson.build
@@ -22,8 +22,10 @@ radv_entrypoints = custom_target(
'radv_entrypoints.[ch]',
input : ['radv_entrypoints_gen.py', vk_api_xml],
output : ['radv_entrypoints.h', 'radv_entrypoints.c'],
- command : [prog_python2, '@INPUT0@', '--xml', '@INPUT1@',
- '--outdir', meson.current_build_dir()],
+ command : [
+ prog_python2, '@INPUT0@', '--xml', '@INPUT1@', '--outdir',
+ meson.current_build_dir()
+ ],
depend_files : files('radv_extensions.py'),
)
@@ -31,8 +33,9 @@ radv_extensions_c = custom_target(
'radv_extensions.c',
input : ['radv_extensions.py', vk_api_xml],
output : ['radv_extensions.c'],
- command : [prog_python2, '@INPUT0@', '--xml', '@INPUT1@',
- '--out', '@OUTPUT@'],
+ command : [
+ prog_python2, '@INPUT0@', '--xml', '@INPUT1@', '--out', '@OUTPUT@',
+ ],
)
vk_format_table_c = custom_target(
@@ -111,13 +114,20 @@ endif
libvulkan_radeon = shared_library(
'vulkan_radeon',
- [libradv_files, radv_entrypoints, radv_extensions_c, nir_opcodes_h, vk_format_table_c],
- include_directories : [inc_common, inc_amd, inc_amd_common, inc_compiler,
- inc_vulkan_util, inc_vulkan_wsi],
- link_with : [libamd_common, libamdgpu_addrlib, libvulkan_util,
- libvulkan_wsi, libnir, libmesa_util],
- dependencies : [dep_llvm, dep_libdrm_amdgpu, dep_thread, dep_elf, dep_dl,
- dep_m, dep_valgrind],
+ [libradv_files, radv_entrypoints, radv_extensions_c, nir_opcodes_h,
+ vk_format_table_c],
+ include_directories : [
+ inc_common, inc_amd, inc_amd_common, inc_compiler, inc_vulkan_util,
+ inc_vulkan_wsi,
+ ],
+ link_with : [
+ libamd_common, libamdgpu_addrlib, libvulkan_util, libvulkan_wsi, libnir,
+ libmesa_util,
+ ],
+ dependencies : [
+ dep_llvm, dep_libdrm_amdgpu, dep_thread, dep_elf, dep_dl, dep_m,
+ dep_valgrind,
+ ],
c_args : [c_vis_args, no_override_init_args, radv_flags],
link_args : [ld_args_bsymbolic, ld_args_gc_sections],
install : true,