aboutsummaryrefslogtreecommitdiffstats
path: root/src/amd/vulkan/meson.build
diff options
context:
space:
mode:
authorBas Nieuwenhuizen <[email protected]>2019-06-25 11:42:03 +0200
committerBas Nieuwenhuizen <[email protected]>2019-10-10 17:02:34 +0000
commitf36b52740a026c46f718a4cb63e70da0322d4b48 (patch)
treeff1f2edc08be697dda6fe6f1c7e5d04501d4434a /src/amd/vulkan/meson.build
parenta34e4dd0d2aa40dd85bf41ab1e1e65e31924df73 (diff)
radv/android: Add android hardware buffer queries.
Derived from the Intel code. For the internal format we just use the internal Vulkan format, as we have Vulkan formats for all android formats we care about. For the ycbcr properties we just do something. I do not have a real clue what would be recommended. Reviewed-by: Samuel Pitoiset <[email protected]>
Diffstat (limited to 'src/amd/vulkan/meson.build')
-rw-r--r--src/amd/vulkan/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/amd/vulkan/meson.build b/src/amd/vulkan/meson.build
index afc5bde56c7..7fa945a346f 100644
--- a/src/amd/vulkan/meson.build
+++ b/src/amd/vulkan/meson.build
@@ -139,6 +139,7 @@ if with_xlib_lease
endif
if with_platform_android
+ radv_deps += dep_android
radv_flags += [
'-DVK_USE_PLATFORM_ANDROID_KHR'
]