aboutsummaryrefslogtreecommitdiffstats
path: root/src/amd/vulkan/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2019-07-22 14:50:15 +0100
committerEric Engestrom <[email protected]>2019-08-03 00:08:37 +0000
commitd2d85b950d78c553b2694cda9ef0cc7bf9a0f737 (patch)
treeafdd28e30b66064b8b540a6e9d6d0ecbe27a6678 /src/amd/vulkan/meson.build
parent8ddb38209d51c53d6e5792b04b97814dfce9bce6 (diff)
meson: replace libmesa_util with idep_mesautil
This automates the include_directories and dependencies tracking so that all users of libmesa_util don't need to add them manually. Next commit will remove the ones that were only added for that reason. Signed-off-by: Eric Engestrom <[email protected]> Acked-by: Eric Anholt <[email protected]> Tested-by: Vinson Lee <[email protected]>
Diffstat (limited to 'src/amd/vulkan/meson.build')
-rw-r--r--src/amd/vulkan/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/amd/vulkan/meson.build b/src/amd/vulkan/meson.build
index b8e62e6617a..0ff6bbdbdd0 100644
--- a/src/amd/vulkan/meson.build
+++ b/src/amd/vulkan/meson.build
@@ -153,12 +153,12 @@ libvulkan_radeon = shared_library(
],
link_with : [
libamd_common, libamdgpu_addrlib, libvulkan_wsi,
- libmesa_util, libxmlconfig
+ libxmlconfig
],
dependencies : [
dep_llvm, dep_libdrm_amdgpu, dep_thread, dep_elf, dep_dl, dep_m,
dep_valgrind, radv_deps,
- idep_nir, idep_vulkan_util, idep_amdgfxregs_h,
+ idep_mesautil, idep_nir, idep_vulkan_util, idep_amdgfxregs_h,
],
c_args : [c_vis_args, no_override_init_args, radv_flags],
cpp_args : [cpp_vis_args, radv_flags],