aboutsummaryrefslogtreecommitdiffstats
path: root/src/amd/vulkan/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-10-11 15:19:04 +0100
committerEric Engestrom <[email protected]>2019-10-13 17:40:54 +0100
commit48289d8853272a1a9bbbb8971aef8f4c2e324266 (patch)
tree305dbec0941b2c146e8efb57841ef0ebe61eab39 /src/amd/vulkan/meson.build
parent960038d550751d9e4d6ac3f4d6f38ad16bc17d53 (diff)
radv: add exported symbols check
Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]> Reviewed-by: Emil Velikov <[email protected]> Reviewed-by: Bas Nieuwenhuizen <[email protected]>
Diffstat (limited to 'src/amd/vulkan/meson.build')
-rw-r--r--src/amd/vulkan/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/amd/vulkan/meson.build b/src/amd/vulkan/meson.build
index 4243f66055f..93523b0e88e 100644
--- a/src/amd/vulkan/meson.build
+++ b/src/amd/vulkan/meson.build
@@ -166,6 +166,19 @@ libvulkan_radeon = shared_library(
install : true,
)
+if with_tests and prog_nm.found()
+ test(
+ 'radv symbols check',
+ symbols_check,
+ args : [
+ '--lib', libvulkan_radeon,
+ '--symbols-file', vulkan_icd_symbols,
+ '--nm', prog_nm.path(),
+ ],
+ suite : ['amd'],
+ )
+endif
+
radeon_icd = custom_target(
'radeon_icd',
input : 'radv_icd.py',