summaryrefslogtreecommitdiffstats
path: root/src/amd/vulkan/meson.build
diff options
context:
space:
mode:
authorBas Nieuwenhuizen <[email protected]>2018-01-04 18:38:32 +0100
committerBas Nieuwenhuizen <[email protected]>2018-01-19 01:43:55 +0100
commitb1444c9ccb06661d932969302d19166df442818c (patch)
tree030cbb2059debe66b295183776ce4676cbeab0f8 /src/amd/vulkan/meson.build
parenta3e241ed07feae592d1fd83db388252816a32849 (diff)
radv: Implement VK_ANDROID_native_buffer.
Passes dEQP-VK.api.smoke.* dEQP-VK.wsi.android.* with android-cts-7.1_r12 . Unlike the initial anv implementation this does use syncobjs instead of waiting on the CPU. This is missing meson build coverage for now. One possible todo is that linux 4.15 now has a sycall that allows us to export amdgpu fence to a sync_file, which allows us not to force all fences and semaphores to use syncobjs. However, I had trouble with my kernel crashing regularly with NULL pointers, and I'm not sure how beneficial it is in the first place given that intel uses syncobjs for all fences if available. Reviewed-by: Dave Airlie <[email protected]>
Diffstat (limited to 'src/amd/vulkan/meson.build')
-rw-r--r--src/amd/vulkan/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/amd/vulkan/meson.build b/src/amd/vulkan/meson.build
index 74f6399ed7f..0a7b7c0bf3c 100644
--- a/src/amd/vulkan/meson.build
+++ b/src/amd/vulkan/meson.build
@@ -31,10 +31,10 @@ radv_entrypoints = custom_target(
radv_extensions_c = custom_target(
'radv_extensions.c',
- input : ['radv_extensions.py', vk_api_xml],
+ input : ['radv_extensions.py', vk_api_xml, vk_android_native_buffer_xml],
output : ['radv_extensions.c'],
command : [
- prog_python2, '@INPUT0@', '--xml', '@INPUT1@', '--out', '@OUTPUT@',
+ prog_python2, '@INPUT0@', '--xml', '@INPUT1@', '--xml', '@INPUT2@', '--out', '@OUTPUT@',
],
)