summaryrefslogtreecommitdiffstats
path: root/src/amd/vulkan/meson.build
diff options
context:
space:
mode:
authorKeith Packard <[email protected]>2018-02-09 07:45:58 -0800
committerKeith Packard <[email protected]>2018-06-19 14:17:46 -0700
commitdbac8e25f851ed44c51f3ce8a08b2cdd564c5dd2 (patch)
treeb916f34db7b01f7ea88f7e5bf979196d8584c56c /src/amd/vulkan/meson.build
parent46090a642d54d58bbdb851ae62beb5c350101324 (diff)
radv: Add EXT_acquire_xlib_display to radv driver [v2]
This extension adds the ability to borrow an X RandR output for temporary use directly by a Vulkan application to the radv driver. v2: Simplify addition of VK_USE_PLATFORM_XLIB_XRANDR_KHR to vulkan_wsi_args Suggested-by: Eric Engestrom <[email protected]> Signed-off-by: Keith Packard <[email protected]> Reviewed-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/amd/vulkan/meson.build')
-rw-r--r--src/amd/vulkan/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/amd/vulkan/meson.build b/src/amd/vulkan/meson.build
index 15e69d582dd..bcdf83e0609 100644
--- a/src/amd/vulkan/meson.build
+++ b/src/amd/vulkan/meson.build
@@ -120,6 +120,11 @@ if with_platform_drm
libradv_files += files('radv_wsi_display.c')
endif
+if with_xlib_lease
+ radv_deps += dep_xcb_xrandr
+ radv_flags += '-DVK_USE_PLATFORM_XLIB_XRANDR_EXT'
+endif
+
libvulkan_radeon = shared_library(
'vulkan_radeon',
[libradv_files, radv_entrypoints, radv_extensions_c, vk_format_table_c],