summaryrefslogtreecommitdiffstats
path: root/src/amd/vulkan/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-07-19 17:53:42 -0700
committerDylan Baker <[email protected]>2017-07-21 14:27:02 -0700
commit59a141c95a7f4008ba5d5d7804fa75e6b8604a06 (patch)
tree033c98374919b6112875a79d70b59e0bf43dedca /src/amd/vulkan/Makefile.am
parentbf24c3539e4b6989512968cae12da2f88d2c53e9 (diff)
radv: rebase radv_entrypoints_gen.py on anv_entrypoints_gen.py
The two generators forked from each other, and they remain basically the same. This rebases the radv version on the anv version, but with the radv changes ported over. The result is that we get rid of the "cat |" madness and gain mako, correct "generated by" attributions, and write files out directly. The only differences between the output is whitespace and comments. Signed-off-by: Dylan Baker <[email protected]> Acked-by: Dave Airlie <[email protected]>
Diffstat (limited to 'src/amd/vulkan/Makefile.am')
-rw-r--r--src/amd/vulkan/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/src/amd/vulkan/Makefile.am b/src/amd/vulkan/Makefile.am
index a645432e74f..3350f545403 100644
--- a/src/amd/vulkan/Makefile.am
+++ b/src/amd/vulkan/Makefile.am
@@ -107,13 +107,11 @@ libvulkan_radeon_la_SOURCES = $(VULKAN_GEM_FILES)
vulkan_api_xml = $(top_srcdir)/src/vulkan/registry/vk.xml
-radv_entrypoints.h : radv_entrypoints_gen.py $(vulkan_api_xml)
- $(AM_V_GEN) cat $(vulkan_api_xml) |\
- $(PYTHON2) $(srcdir)/radv_entrypoints_gen.py header > $@
-
-radv_entrypoints.c : radv_entrypoints_gen.py $(vulkan_api_xml)
- $(AM_V_GEN) cat $(vulkan_api_xml) |\
- $(PYTHON2) $(srcdir)/radv_entrypoints_gen.py code > $@
+radv_entrypoints.c: radv_entrypoints_gen.py $(vulkan_api_xml)
+ $(MKDIR_GEN)
+ $(AM_V_GEN)$(PYTHON2) $(srcdir)/radv_entrypoints_gen.py \
+ --xml $(vulkan_api_xml) --outdir $(builddir)
+radv_entrypoints.h: radv_entrypoints.c
vk_format_table.c: vk_format_table.py \
vk_format_parse.py \