summaryrefslogtreecommitdiffstats
path: root/src/amd/vulkan/Makefile.am
diff options
context:
space:
mode:
authorDave Airlie <[email protected]>2016-10-14 07:49:34 +0100
committerDave Airlie <[email protected]>2016-10-19 10:15:43 +1000
commit6c3bd1cdb3c60a0140b57a2064e02f5869b0f9bc (patch)
tree3e59e634ae3fdfce6944737431db5584db2c84b0 /src/amd/vulkan/Makefile.am
parent3f7ef2488938d31b5ead043891fadc3cee4c6f05 (diff)
radv: port to common wsi codebase
This drops all the radv WSI code in favour of using the new shared code that was ported from anv This regresses Talos for now, Jason has pointed out the bug is in Talos and we should wait for them to fix it. Reviewed-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/amd/vulkan/Makefile.am')
-rw-r--r--src/amd/vulkan/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/amd/vulkan/Makefile.am b/src/amd/vulkan/Makefile.am
index e2f5c029a07..44d2a6660bc 100644
--- a/src/amd/vulkan/Makefile.am
+++ b/src/amd/vulkan/Makefile.am
@@ -38,6 +38,7 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/include \
-I$(top_builddir)/src \
-I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/vulkan/wsi \
-I$(top_srcdir)/src/amd \
-I$(top_srcdir)/src/amd/common \
-I$(top_builddir)/src/compiler \
@@ -93,6 +94,7 @@ libvulkan_common_la_SOURCES = $(VULKAN_SOURCES)
VULKAN_LIB_DEPS += \
libvulkan_common.la \
+ $(top_builddir)/src/vulkan/wsi/libvulkan_wsi.la \
$(top_builddir)/src/amd/common/libamd_common.la \
$(top_builddir)/src/amd/addrlib/libamdgpu_addrlib.la \
$(top_builddir)/src/compiler/nir/libnir.la \