summaryrefslogtreecommitdiffstats
path: root/src/amd/vulkan/Makefile.am
diff options
context:
space:
mode:
authorAndres Rodriguez <[email protected]>2017-01-18 17:48:36 -0500
committerEmil Velikov <[email protected]>2017-01-19 15:41:38 +0000
commita3ad6a34c6ba222ec93a2cfd0cac205c62574eb7 (patch)
tree851992e8560233e43ec6f3735a0117a5e4838b25 /src/amd/vulkan/Makefile.am
parent0f8afde7baf2b4764c3832387607021f2d318f6e (diff)
radv: fix include order for installed headers v2
In situations where libdrm_amdgpu and mesa are installed to the same location, the mesa installed headers will take precedence over the git source headers. This is due to the AMDGPU_CFLAGS containing the install directory. This situation can cause build errors if the git version of a header is newer than the currently installed version of a header (e.g. git pull updates vulkan.h) Note: using the same install prefix for mesa and libdrm is probably a common occurrence since it is described in the radeonBuildHowTo wiki: https://www.x.org/wiki/radeonBuildHowTo/ v2: added sign-off Signed-off-by: Andres Rodriguez <[email protected]> Reviewed-by: Bas Nieuwenhuizen <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/amd/vulkan/Makefile.am')
-rw-r--r--src/amd/vulkan/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/amd/vulkan/Makefile.am b/src/amd/vulkan/Makefile.am
index 44148817bcd..b47109bd5a8 100644
--- a/src/amd/vulkan/Makefile.am
+++ b/src/amd/vulkan/Makefile.am
@@ -32,9 +32,6 @@ lib_LTLIBRARIES = libvulkan_radeon.la
# The gallium includes are for the util/u_math.h include from main/macros.h
AM_CPPFLAGS = \
- $(AMDGPU_CFLAGS) \
- $(VALGRIND_CFLAGS) \
- $(DEFINES) \
-I$(top_srcdir)/include \
-I$(top_builddir)/src \
-I$(top_srcdir)/src \
@@ -48,7 +45,10 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/src/mesa \
-I$(top_srcdir)/src/mesa/drivers/dri/common \
-I$(top_srcdir)/src/gallium/auxiliary \
- -I$(top_srcdir)/src/gallium/include
+ -I$(top_srcdir)/src/gallium/include \
+ $(AMDGPU_CFLAGS) \
+ $(VALGRIND_CFLAGS) \
+ $(DEFINES)
AM_CFLAGS = \
$(VISIBILITY_CFLAGS) \