aboutsummaryrefslogtreecommitdiffstats
path: root/src/amd/vulkan/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-08-24 11:14:15 +0100
committerEmil Velikov <[email protected]>2018-08-24 11:14:15 +0100
commitcff80b6c153661ed40a207815a3d3a132daae656 (patch)
tree9942a8361e0d4d7662af8e782c21388a725880b1 /src/amd/vulkan/Makefile.am
parent7a4d2d1fdf3fd6dd79cda971b5b3669fc7fbc729 (diff)
Revert "configure: allow building with python3"
This reverts commit ae7898dfdbe5c8dab7d11c71862353f1ae43feb0. Turns out the python scripts are _not_ fully python 3 compatible. As Ilia reported using get_xmlpool.py with LANG=C produces some weird output - see the link for details. Even though the issue was spotted with the autoconf build, it exposes a genuine problem with the script (and lack of lang handling of the meson build.) https://lists.freedesktop.org/archives/mesa-dev/2018-August/203508.html
Diffstat (limited to 'src/amd/vulkan/Makefile.am')
-rw-r--r--src/amd/vulkan/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/amd/vulkan/Makefile.am b/src/amd/vulkan/Makefile.am
index 2522171dacf..e28f032cbee 100644
--- a/src/amd/vulkan/Makefile.am
+++ b/src/amd/vulkan/Makefile.am
@@ -140,7 +140,7 @@ vulkan_api_xml = $(top_srcdir)/src/vulkan/registry/vk.xml
radv_entrypoints.c: radv_entrypoints_gen.py radv_extensions.py $(vulkan_api_xml)
$(MKDIR_GEN)
- $(AM_V_GEN)$(PYTHON) $(srcdir)/radv_entrypoints_gen.py \
+ $(AM_V_GEN)$(PYTHON2) $(srcdir)/radv_entrypoints_gen.py \
--xml $(vulkan_api_xml) \
--outdir $(builddir)
radv_entrypoints.h: radv_entrypoints.c
@@ -148,7 +148,7 @@ radv_entrypoints.h: radv_entrypoints.c
radv_extensions.c: radv_extensions.py \
$(vulkan_api_xml)
$(MKDIR_GEN)
- $(AM_V_GEN)$(PYTHON) $(srcdir)/radv_extensions.py \
+ $(AM_V_GEN)$(PYTHON2) $(srcdir)/radv_extensions.py \
--xml $(vulkan_api_xml) \
--out-c radv_extensions.c \
--out-h radv_extensions.h
@@ -157,7 +157,7 @@ radv_extensions.h: radv_extensions.c
vk_format_table.c: vk_format_table.py \
vk_format_parse.py \
vk_format_layout.csv
- $(PYTHON) $(srcdir)/vk_format_table.py $(srcdir)/vk_format_layout.csv > $@
+ $(PYTHON2) $(srcdir)/vk_format_table.py $(srcdir)/vk_format_layout.csv > $@
BUILT_SOURCES = $(VULKAN_GENERATED_FILES)
CLEANFILES = $(BUILT_SOURCES) dev_icd.json radeon_icd.@[email protected]
@@ -190,11 +190,11 @@ icdconf_DATA = radeon_icd.@[email protected]
noinst_DATA = dev_icd.json
dev_icd.json : radv_extensions.py radv_icd.py
- $(AM_V_GEN)$(PYTHON) $(srcdir)/radv_icd.py \
+ $(AM_V_GEN)$(PYTHON2) $(srcdir)/radv_icd.py \
--lib-path="${abs_top_builddir}/${LIB_DIR}" --out $@
radeon_icd.@[email protected] : radv_extensions.py radv_icd.py
- $(AM_V_GEN)$(PYTHON) $(srcdir)/radv_icd.py \
+ $(AM_V_GEN)$(PYTHON2) $(srcdir)/radv_icd.py \
--lib-path="${libdir}" --out $@
include $(top_srcdir)/install-lib-links.mk