summaryrefslogtreecommitdiffstats
path: root/src/amd/common/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-09-20 11:53:29 -0700
committerDylan Baker <[email protected]>2017-09-27 09:12:34 -0700
commit673dda8330769309a319d3e7f24a029cd72a1caf (patch)
treee6418ab1566d57904f24b5e85fc03f47497aaf91 /src/amd/common/meson.build
parentd1992255bb29054fa51763376d125183a9f602f3 (diff)
meson: build "radv" vulkan driver for radeon hardware
This builds, installs, and has been tested on a r290x (Hawaii) with the Vulkan CTS. It dies horribly in a fire at the same point for the meson build as the autotools build. v2: - enable radv by default - add shader cache support and enforce that it's built for radv v3: - Fix typo in meson_options (Nicholas) - strip trailing 'svn' from llvm version before setting the version preprocessor flag (Bas) - Check for LLVM module requirements Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Bas Nieuwenhuizen <[email protected]>
Diffstat (limited to 'src/amd/common/meson.build')
-rw-r--r--src/amd/common/meson.build63
1 files changed, 63 insertions, 0 deletions
diff --git a/src/amd/common/meson.build b/src/amd/common/meson.build
new file mode 100644
index 00000000000..842b42f897e
--- /dev/null
+++ b/src/amd/common/meson.build
@@ -0,0 +1,63 @@
+# Copyright © 2017 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+inc_amd_common = include_directories('.')
+
+sid_tables_h = custom_target(
+ 'sid_tables_h',
+ input : ['sid_tables.py', 'sid.h', 'gfx9d.h'],
+ output : 'sid_tables.h',
+ command : [prog_python2, '@INPUT@'],
+ capture : true,
+)
+
+amd_common_files = files(
+ 'ac_binary.c',
+ 'ac_binary.h',
+ 'ac_exp_param.h',
+ 'ac_llvm_build.c',
+ 'ac_llvm_build.h',
+ 'ac_llvm_helper.cpp',
+ 'ac_llvm_util.c',
+ 'ac_llvm_util.h',
+ 'ac_shader_abi.h',
+ 'ac_shader_info.c',
+ 'ac_shader_info.h',
+ 'ac_nir_to_llvm.c',
+ 'ac_nir_to_llvm.h',
+ 'ac_gpu_info.c',
+ 'ac_gpu_info.h',
+ 'ac_surface.c',
+ 'ac_surface.h',
+ 'ac_debug.c',
+ 'ac_debug.h',
+)
+
+libamd_common = static_library(
+ 'amd_common',
+ [amd_common_files, sid_tables_h, nir_opcodes_h],
+ include_directories : [inc_common, inc_compiler, inc_nir, inc_mesa, inc_mapi,
+ inc_amd],
+ dependencies : [dep_llvm, dep_thread, dep_elf, dep_libdrm_amdgpu,
+ dep_valgrind],
+ c_args : [c_vis_args],
+ cpp_args : [cpp_vis_args],
+ build_by_default : false,
+)