aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorArmin K <[email protected]>2013-08-11 17:27:23 +0200
committerKristian Høgsberg <[email protected]>2013-08-12 15:16:22 -0700
commitf423eba46e080b975a2b8366b490d99dee4729ad (patch)
treec36baeb655388c593367727dc88419e74e16a8f3 /src/Makefile.am
parentcd2f26090a3857703bc85bd58ac5922800b06bc0 (diff)
gbm: Link to libwayland-drm if Wayland EGL platform is enabled
We were relying on libEGL to pull in libwayland-client symbols, but with commit 2c2e64edaba0f6aeb181ca5b51eb8dea8e9b39f9 cleaned up the symbol leak. https://bugs.freedesktop.org/show_bug.cgi?id=67962
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b3dc44d6fd6..76280a0c02e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -29,6 +29,10 @@ if HAVE_DRI_GLX
SUBDIRS += glx
endif
+if HAVE_EGL_PLATFORM_WAYLAND
+SUBDIRS += egl/wayland
+endif
+
if HAVE_GBM
SUBDIRS += gbm
endif