summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2017-10-25 14:04:35 +0100
committerEric Engestrom <[email protected]>2017-10-27 13:38:37 +0100
commit7088622e5fb506b64c906b673a9af0feb9a5ba14 (patch)
treebcf6b8c47f47e9ebe43a7781e4016c2817127d04 /src/Makefile.am
parenta41e2e9cf5f865f21e32cac2ed2e25dd21a05119 (diff)
buildsys: move file regeneration logic to the script itself
Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Jordan Justen <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 4 insertions, 11 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5ef2d4f55ea..1de4fca6a12 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,17 +19,10 @@
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
# IN THE SOFTWARE.
-.PHONY: git_sha1.h.tmp
-git_sha1.h.tmp:
- @$(PYTHON2) $(top_srcdir)/bin/git_sha1_gen.py > $@
-
-git_sha1.h: git_sha1.h.tmp
- @echo "updating git_sha1.h"
- @if ! cmp -s git_sha1.h.tmp git_sha1.h; then \
- mv git_sha1.h.tmp git_sha1.h ;\
- else \
- rm git_sha1.h.tmp ;\
- fi
+.PHONY: git_sha1.h
+git_sha1.h: $(top_srcdir)/src/git_sha1.h.in
+ @echo "updating $@"
+ @$(PYTHON2) $(top_srcdir)/bin/git_sha1_gen.py --output $@
BUILT_SOURCES = git_sha1.h
CLEANFILES = $(BUILT_SOURCES)