summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJose Fonseca <[email protected]>2017-08-01 14:36:16 +0100
committerJose Fonseca <[email protected]>2017-08-01 15:24:39 +0100
commitb99dcbfeb344390fea9919199b34e5504f7c84e3 (patch)
treea7ebdd094311f016fb8a8b4f618f540bf647e159 /src/Makefile.am
parent1bc8b2c0ebbc5f5d930058d5214b724468f981c2 (diff)
build: Convert git_sha1_gen script to Python.
Python is the scripting language we've been using for scripts that need to run across all supported platforms. Shell is *not* a portable language for scripts. Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5aee6b01417..8d7483fc758 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -21,7 +21,7 @@
.PHONY: git_sha1.h.tmp
git_sha1.h.tmp:
- @sh $(top_srcdir)/bin/git_sha1_gen.sh > $@
+ @python $(top_srcdir)/bin/git_sha1_gen.py > $@
git_sha1.h: git_sha1.h.tmp
@echo "updating git_sha1.h"