summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-02-15 15:41:50 -0800
committerDylan Baker <[email protected]>2017-02-22 13:12:02 -0800
commite9dcb17962f7e58a81c93bae7bd33885675b1043 (patch)
tree55332d8cdb6783ab65fc8d34e4df8168fb38dcab /src/Makefile.am
parentbda59f6e417b68985ffc8dbb92fcfe19ba12f7bf (diff)
vulkan/util: Add generator for enum_to_str functions
This adds a python generator to produce enum_to_str functions for Vulkan from the vk.xml API description. It supports extensions as well as core API features, and the generator works with both python2 and python3. Signed-off-by: Dylan Baker <[email protected]> Acked-by: Matt Turner <[email protected]> Acked-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 12e5dcdb12a..cbdf378c54b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -117,7 +117,7 @@ SUBDIRS += intel/tools
endif
if HAVE_VULKAN_COMMON
-SUBDIRS += vulkan/wsi
+SUBDIRS += vulkan/util vulkan/wsi
endif
EXTRA_DIST += vulkan/registry/vk.xml