aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2019-09-26 15:42:59 -0700
committerDylan Baker <[email protected]>2019-09-27 16:39:01 +0000
commite456a053c3d6ec4f3d4581edcad05c72dfdaa407 (patch)
tree36958928a7e7c634a9e0ed10afca86d9ef6e907f /meson.build
parent8c5c21d7e337bbaffe8d68d9abbb166a271b35cc (diff)
meson: Link xvmc with libxv
Prior to xvmc 1.0.12 libxvmc incorrectly required libxv, but that was fixed. This results in compilation failures for the gallium xvmc tracker and tools. This patch fixes that by explicitly linking to libxv. Fixes: 22a817af8a89eb3c762fc3e07b443a3ce37d7416 ("meson: build gallium xvmc state tracker") Closes: https://gitlab.freedesktop.org/mesa/mesa/issues/1844 Reviewed-by: Adam Jackson <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index da4a07538df..aea5c2e4444 100644
--- a/meson.build
+++ b/meson.build
@@ -516,10 +516,12 @@ elif not (with_gallium_r600 or with_gallium_nouveau)
endif
endif
dep_xvmc = null_dep
+dep_xv = null_dep
with_gallium_xvmc = false
if _xvmc != 'false'
dep_xvmc = dependency('xvmc', version : '>= 1.0.6', required : _xvmc == 'true')
- with_gallium_xvmc = dep_xvmc.found()
+ dep_xv = dependency('xv', required : _xvmc == 'true')
+ with_gallium_xvmc = dep_xvmc.found() and dep_xv.found()
endif
xvmc_drivers_path = get_option('xvmc-libs-path')