aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-05-14 16:40:47 +0100
committerMarge Bot <[email protected]>2020-06-02 19:36:12 +0000
commitd32144602c1dfd507f07774ce906dc25d2697da0 (patch)
tree8317c18a9b64b9ac7abf1805e7700cbe47234848 /meson.build
parenta2903dd767f77edccb671f30e9e0686b50879cca (diff)
meson: remove "empty array"/"array of an empty string" confusion
Until Meson 0.47, setting `-D arrayoption=` was not the same as setting `-D arrayoption=[]`; the latter cleared the array, while the former filled it with an empty string option. Since Meson 0.47 [1], the former maps to the latter, so empty items can only be set by explicitly giving an array containing an empty string, ie. `-D arrayoption="['']"`; however note that this is *not* what we want in any of the current Mesa code anyway. This makes the code handling array options a bit more complicated, and a lot more error-prone, so let's get rid of the confusion by removing the empty-string option. [1] https://github.com/mesonbuild/meson/commit/f3a8f9c34d95d862fb4d12869a7b31cea592561f Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/386>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 7 insertions, 13 deletions
diff --git a/meson.build b/meson.build
index 8d89bf9781e..1932410fcf7 100644
--- a/meson.build
+++ b/meson.build
@@ -181,7 +181,7 @@ with_dri_r200 = dri_drivers.contains('r200')
with_dri_nouveau = dri_drivers.contains('nouveau')
with_dri_swrast = dri_drivers.contains('swrast')
-with_dri = dri_drivers.length() != 0 and dri_drivers != ['']
+with_dri = dri_drivers.length() != 0
gallium_drivers = get_option('gallium-drivers')
if gallium_drivers.contains('auto')
@@ -228,7 +228,7 @@ with_gallium_swr = gallium_drivers.contains('swr')
with_gallium_lima = gallium_drivers.contains('lima')
with_gallium_zink = gallium_drivers.contains('zink')
-with_gallium = gallium_drivers.length() != 0 and gallium_drivers != ['']
+with_gallium = gallium_drivers.length() != 0
if with_gallium and system_has_kms_drm
_glx = get_option('glx')
@@ -261,7 +261,7 @@ endif
with_intel_vk = _vulkan_drivers.contains('intel')
with_amd_vk = _vulkan_drivers.contains('amd')
with_freedreno_vk = _vulkan_drivers.contains('freedreno')
-with_any_vk = _vulkan_drivers.length() != 0 and _vulkan_drivers != ['']
+with_any_vk = _vulkan_drivers.length() != 0
if with_dri_swrast and (with_gallium_softpipe or with_gallium_swr)
error('Only one swrast provider can be built')
@@ -314,13 +314,7 @@ with_platform_haiku = _platforms.contains('haiku')
with_platform_surfaceless = _platforms.contains('surfaceless')
with_platform_windows = _platforms.contains('windows')
-with_platforms = false
-if _platforms.length() != 0 and _platforms != ['']
- # sanity check that list contains no empty strings
- if _platforms.contains('')
- error('Invalid argument list given to -Dplatforms, please fix.')
- endif
- with_platforms = true
+if _platforms.length() != 0
egl_native_platform = _platforms[0]
endif
@@ -399,14 +393,14 @@ endif
if _egl == 'auto'
with_egl = (
not ['darwin', 'windows'].contains(host_machine.system()) and
- with_dri and with_shared_glapi and with_platforms
+ with_dri and with_shared_glapi and _platforms.length() != 0
)
elif _egl == 'enabled'
if not with_dri
error('EGL requires dri')
elif not with_shared_glapi
error('EGL requires shared-glapi')
- elif not with_platforms
+ elif _platforms.length() == 0
error('No platforms specified, consider -Dplatforms=drm,x11,surfaceless at least')
elif not ['disabled', 'dri'].contains(with_glx)
error('EGL requires dri, but a GLX is being built without dri')
@@ -1898,7 +1892,7 @@ if with_egl
lines += 'EGL drivers: ' + ' '.join(egl_drivers)
endif
lines += 'GBM: ' + (with_gbm ? 'yes' : 'no')
-if with_platforms
+if _platforms.length() != 0
lines += 'EGL/Vulkan/VL platforms: ' + ' '.join(_platforms)
endif