aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorBas Nieuwenhuizen <[email protected]>2019-10-31 12:00:52 +0100
committerMarge Bot <[email protected]>2020-01-02 11:47:02 +0000
commitc1a1a86658303083d33e70c6b0c1b3317bdd8d20 (patch)
treef284302dd481c4d8f176eb963923c04077c1929d /meson.build
parentb72182fcfa624b2cd7e19dd6c8e5ae60b2679dde (diff)
meson: Enable -Werror=int-conversion.
I think implicit conversions here are almost always wrong: 1) wrong argument position ptr vs. int 2) will often have issues with 32-bit platforms. Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]> Reviewed-by: Kristian H. Kristensen <[email protected]> Tested-by: Marge Bot <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/2570> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/2570>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 5b488313309..35cd2e6f632 100644
--- a/meson.build
+++ b/meson.build
@@ -951,6 +951,7 @@ else
'-Werror=return-type',
'-Werror=empty-body',
'-Werror=incompatible-pointer-types',
+ '-Werror=int-conversion',
'-Wno-missing-field-initializers',
'-Wno-format-truncation',
'-fno-math-errno',