aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorJon Turney <[email protected]>2018-08-02 14:50:27 +0100
committerJon Turney <[email protected]>2018-08-02 18:12:49 +0100
commita48c0659e12bfb2d715cceca75eff24ae6024bba (patch)
treeea0b4cb2ad2d8d35983d7bce148e73668b401dd4 /meson.build
parent3013e22717b7716a0b55e9f34e4d20750eb5d1a1 (diff)
meson: use correct keyword to fix a meson warning
With a sufficently recent meson, the following warning is produced: WARNING: Passed invalid keyword argument "extra_args". WARNING: This will become a hard error in the future. It seems that compiler.links(args:) is meant here. Signed-off-by: Jon Turney <[email protected]> Reviewed-and-Tested-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 86a4a4ce6da..cbf88b50139 100644
--- a/meson.build
+++ b/meson.build
@@ -989,7 +989,7 @@ if cc.links('''
freelocale(loc);
return 0;
}''',
- extra_args : pre_args,
+ args : pre_args,
name : 'strtod has locale support')
pre_args += '-DHAVE_STRTOD_L'
endif