aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-06-07 10:48:38 -0700
committerDylan Baker <[email protected]>2018-06-07 11:54:06 -0700
commit8f2421d73be596c12019196189255f22fd3edb54 (patch)
tree682008c5e82f3e0bf7df9912bbd398dce0a66145 /meson.build
parente0fa2399628b8cfa06785647c2750b3c206e6563 (diff)
meson: work around gentoo applying -m32 to host compiler in cross builds
Gentoo's ebuild system always adds -m32 to the compiler for doing x86_64 -> x86 cross builds, while meson expects it not to do that. This results in an x86 -> x86 cross build, and assembly gets disabled. Fixes: 2d62fc06465281d3d45b8a7c7fd2b17ef718448c ("meson: disable x86 asm in fewer cases.") Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 32ab30faa4b..e6e2167ebe7 100644
--- a/meson.build
+++ b/meson.build
@@ -852,7 +852,10 @@ if meson.is_cross_build()
# TODO: It may be possible to do this with an exe_wrapper (like wine).
message('Cross compiling from one OS to another, disabling assembly.')
with_asm = false
- elif not (build_machine.cpu_family() == 'x86_64' and host_machine.cpu_family() == 'x86')
+ elif not (build_machine.cpu_family().startswith('x86') and host_machine.cpu_family() == 'x86')
+ # FIXME: Gentoo always sets -m32 for x86_64 -> x86 builds, resulting in an
+ # x86 -> x86 cross compile. We use startswith rather than == to handle this
+ # case.
# TODO: There may be other cases where the 64 bit version of the
# architecture can run 32 bit binaries (aarch64 and armv7 for example)
message('''