aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-06-07 15:45:01 +0100
committerEric Engestrom <[email protected]>2018-06-08 16:45:43 +0100
commit37eb56d239986e2e7ca1c87d08fd357378a3a06e (patch)
tree6d65cb2e6a1285c67b4524718c0be6a12a6bda08 /meson.build
parentcb03803253b026d5f4c1e0fef431a12df461e6d8 (diff)
autotools/meson: compile against wayland-egl-*backend*
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=106861 Fixes: 1db4ec05462914096b1f "egl: rewire the build systems to use libwayland-egl" Suggested-by: Emil Velikov <[email protected]> Tested-by: Andreas Hartmetz <[email protected]> Signed-off-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 636d0f913ac..160bbfa30ba 100644
--- a/meson.build
+++ b/meson.build
@@ -1220,7 +1220,9 @@ if with_platform_wayland
dep_wayland_client = dependency('wayland-client', version : '>=1.11')
dep_wayland_server = dependency('wayland-server', version : '>=1.11')
if with_egl
- dep_wayland_egl = dependency('wayland-egl', version : '>=1.15')
+ dep_wayland_egl = dependency('wayland-egl-backend', version : '>= 3')
+ dep_wayland_egl_headers = declare_dependency(
+ compile_args : run_command(prog_pkgconfig, ['wayland-egl-backend', '--cflags']).stdout().split())
endif
wayland_dmabuf_xml = join_paths(
dep_wl_protocols.get_pkgconfig_variable('pkgdatadir'), 'unstable',