aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPierre-Eric Pelloux-Prayer <[email protected]>2020-03-05 11:00:28 +0100
committerPierre-Eric Pelloux-Prayer <[email protected]>2020-03-09 09:11:07 +0100
commit33b255e107b470b8d2ea5bd96d82c613244aaf47 (patch)
tree8afb3fa88166e926fd8fc29ae001baa2e0f829f9 /meson.build
parent283e815339a15fa99039c69f1e225269790ae955 (diff)
meson: enable -fno-common by default
This flag is enabled by default starting with gcc 10. All the compilation issues have been fixed, so use it by default to make sure we're not introducing regressions. Reviewed-by: Michel Dänzer <[email protected]> Tested-by: Marge Bot <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4058> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4058>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1484e7fec5d..bf306605645 100644
--- a/meson.build
+++ b/meson.build
@@ -958,6 +958,7 @@ else
'-fno-math-errno',
'-fno-trapping-math',
'-Qunused-arguments',
+ '-fno-common',
]
# MinGW chokes on format specifiers and I can't get it all working
if not (cc.get_id() == 'gcc' and host_machine.system() == 'windows')