aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-05-10 16:12:12 +0100
committerEric Engestrom <[email protected]>2018-06-01 17:53:06 +0100
commit03a2e7b6627a99222b4ca4777047bbe2b8186c7b (patch)
treeddb2985f13e2619a85291d77eb9e263bba781926 /meson.build
parent0ed6a87a106b6e2266e01c5d7e31344229833c8d (diff)
meson: drop unused empty string array element
Signed-off-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index ab99c263139..7b7c118d77b 100644
--- a/meson.build
+++ b/meson.build
@@ -100,13 +100,13 @@ if _drivers.contains('auto')
if ['x86', 'x86_64'].contains(host_machine.cpu_family())
_drivers = ['i915', 'i965', 'r100', 'r200', 'nouveau']
elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
- _drivers = ['']
+ _drivers = []
else
error('Unknown architecture. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.')
endif
elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
# only swrast would make sense here, but gallium swrast is a much better default
- _drivers = ['']
+ _drivers = []
else
error('Unknown OS. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.')
endif
@@ -180,7 +180,7 @@ if _vulkan_drivers.contains('auto')
endif
elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
# No vulkan driver supports windows or macOS currently
- _vulkan_drivers = ['']
+ _vulkan_drivers = []
else
error('Unknown OS. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.')
endif