summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-09-28 10:48:30 -0700
committerDylan Baker <[email protected]>2017-10-02 09:33:19 -0700
commit9342a7d6d64dce331a5efff269b50564c867ba62 (patch)
tree5c27a8e44335cbf233e122c1b2ac8de5d0da6c65 /meson.build
parent86a82b6af99036380523b13314d8b2cd52887c90 (diff)
meson: check for python2 mako
Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 02f43eec230..329495ee1b3 100644
--- a/meson.build
+++ b/meson.build
@@ -53,6 +53,10 @@ if _vulkan_drivers != ''
endif
prog_python2 = find_program('python2')
+has_mako = run_command(prog_python2, '-c', 'import mako')
+if has_mako.returncode() != 0
+ error('Python (2.x) mako module required to build mesa.')
+endif
cc = meson.get_compiler('c')
if cc.get_id() == 'gcc' and cc.version().version_compare('< 4.4.6')