summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarek Olšák <[email protected]>2018-02-02 19:26:49 +0100
committerMarek Olšák <[email protected]>2018-02-02 23:47:40 +0100
commit3bf1e036e8ad196fe669ac24da8c14ff160399d8 (patch)
tree79ef57ee0ba2dba500cd463393d300555cc987ac /meson.build
parentc75a4e5b465261e982ea31ef875325a3cc30e79d (diff)
amd: remove support for LLVM 3.9
Only these are supported: - LLVM 4.0 - LLVM 5.0 - LLVM 6.0 - master (7.0) Reviewed-by: Dylan Baker <[email protected]> Reviewed-by: Bas Nieuwenhuizen <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index cb3b6587b4d..a806aefa07f 100644
--- a/meson.build
+++ b/meson.build
@@ -992,9 +992,9 @@ if with_gallium_opencl
# TODO: optional modules
endif
-if with_amd_vk
+if with_amd_vk or with_gallium_radeonsi
_llvm_version = '>= 4.0.0'
-elif with_gallium_opencl or with_gallium_swr or with_gallium_r600 or with_gallium_radeonsi
+elif with_gallium_opencl or with_gallium_swr or with_gallium_r600
_llvm_version = '>= 3.9.0'
else
_llvm_version = '>= 3.3.0'
@@ -1031,7 +1031,7 @@ if with_llvm
'-DMESA_LLVM_VERSION_PATCH=@0@'.format(_llvm_patch),
]
elif with_amd_vk or with_gallium_radeonsi or with_gallium_swr
- error('The following drivers requires LLVM: Radv, RadeonSI, SWR. One of these is enabled, but LLVM is disabled.')
+ error('The following drivers require LLVM: Radv, RadeonSI, SWR. One of these is enabled, but LLVM is disabled.')
endif
dep_glvnd = []