summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorScott D Phillips <[email protected]>2018-01-24 11:24:12 -0800
committerDylan Baker <[email protected]>2018-01-24 11:32:34 -0800
commit0b8d38bd48b219bd979b2ee0ef1ce2b7184f7095 (patch)
tree8ac6b08d0cc34d8c4703d620f44ee91c624d3ab3 /meson.build
parent8172b9ff48ba4d28ae1b8d87b7c24aa082237516 (diff)
meson: Fix define for USE_SSE41
Before we were adding -DHAVE_SSE41 which isn't what the code is looking for, so some uses of the sse4.1 code were always being skipped. v2: Don't add any compile check for the quite old -msse4.1 option (Dylan) Fixes: 84486f6462 ("meson: Enable SSE4.1 optimizations") Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 97619f786bb..eb85a4a5938 100644
--- a/meson.build
+++ b/meson.build
@@ -772,7 +772,7 @@ foreach a : ['-Werror=pointer-arith', '-Werror=vla']
endforeach
if host_machine.cpu_family().startswith('x86')
- pre_args += '-DHAVE_SSE41'
+ pre_args += '-DUSE_SSE41'
with_sse41 = true
sse41_args = ['-msse4.1']