summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Stone <[email protected]>2017-06-08 17:24:30 +0100
committerDaniel Stone <[email protected]>2018-03-09 17:47:13 +0000
commitc80c08e226033e9e33abdca43e02e7f8c845ae0a (patch)
tree055cff1a4db8f60e833f3aee9c2773429d417089 /meson.build
parent7258be91c59b20a6479b3b0d750ff8b4a32cf032 (diff)
vulkan/wsi/x11: Add support for DRI3 v1.2
Adds support for multiple planes and buffer modifiers. v4: Rename "has_dri3_v1_1" to "has_dri3_modifiers" v12: Multi-planar/modifier support is now DRI3 v1.2; also update release versions
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7658f6e63da..34090de4525 100644
--- a/meson.build
+++ b/meson.build
@@ -1234,7 +1234,7 @@ if with_platform_x11
if with_dri3
pre_args += '-DHAVE_DRI3'
- dep_xcb_dri3 = dependency('xcb-dri3')
+ dep_xcb_dri3 = dependency('xcb-dri3', version : '>= 1.13')
dep_xcb_present = dependency('xcb-present')
dep_xcb_sync = dependency('xcb-sync')
dep_xshmfence = dependency('xshmfence', version : '>= 1.1')