summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-11 12:49:31 -0700
committerDylan Baker <[email protected]>2017-10-16 16:32:43 -0700
commit8e611878c4dfaa4157e14e356ea7b5f9ecf44364 (patch)
treed6769e6bd492e7f57c39647704d376a87aadbe77 /meson.build
parent90b5ec6c5f225a1f6f4b23d1632b2d842ed7ece0 (diff)
meson: always set GLX_USE_TLS
This can be applied to all GLX implementations, and in autotools this is guarded only by the --enable-glx-tls flag. Since this is on by default in autotools, and is strictly better than being off, the meson build doesn't even have a toggle for it. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e68469262bf..17187f3d909 100644
--- a/meson.build
+++ b/meson.build
@@ -151,9 +151,9 @@ else
with_gbm = false
endif
+pre_args += '-DGLX_USE_TLS'
with_glx = get_option('glx')
if with_glx != 'disabled'
- pre_args += '-DGLX_USE_TLS'
if not (with_platform_x11 and with_any_opengl) and with_glx != 'auto'
error('Cannot build GLX support without X11 platform support and at least one OpenGL API')
elif with_glx == 'gallium-xlib'