summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorJon Turney <[email protected]>2018-01-15 19:39:46 +0000
committerJon Turney <[email protected]>2018-01-17 18:05:18 +0000
commit3c35dad1dfd108db082a46ee45da6633e244eb92 (patch)
tree691acc232edbd2a139897e38c121a9dc9bf3fa7f /meson.build
parent22a2027dd7784d32b911e37e0bf440b099d7cc02 (diff)
meson: Set with_dri from with_gallium when DRI glx is explicitly configured
Set with_dri from with_gallium when DRI GLX is explicitly configured, as well as when DRI GLX is chosen automatically. Signed-off-by: Jon Turney <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ae31cdd6571..f3179c38062 100644
--- a/meson.build
+++ b/meson.build
@@ -248,7 +248,6 @@ if with_glx == 'auto'
elif with_gallium
# Even when building just gallium drivers the user probably wants dri
with_glx = 'dri'
- with_dri = true
elif with_platform_x11 and with_any_opengl and not with_any_vk
# The automatic behavior should not be to turn on xlib based glx when
# building only vulkan drivers
@@ -257,6 +256,11 @@ if with_glx == 'auto'
with_glx = 'disabled'
endif
endif
+if with_glx == 'dri'
+ if with_gallium
+ with_dri = true
+ endif
+endif
if not (with_dri or with_gallium or with_glx == 'xlib' or with_glx == 'gallium-xlib')
with_gles1 = false