summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-11-15 17:07:37 -0800
committerDylan Baker <[email protected]>2017-11-22 12:46:00 -0800
commite89842ebbcab66d17c372e993dadfadcd91c2a6d (patch)
tree9c514b441737df6df92b890636d0f67339ef50d1 /meson.build
parent2d62fc06465281d3d45b8a7c7fd2b17ef718448c (diff)
meson: Fix TODO for missing dl_iterate_phdr function
This function is required for both the Intel "Anvil" vulkan driver and the i965 GL driver. Error out if either of those is enabled but this function isn't found. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Emil Velikov <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 23ed42ec0f9..f844289821a 100644
--- a/meson.build
+++ b/meson.build
@@ -660,8 +660,10 @@ endif
if cc.has_function('dl_iterate_phdr')
pre_args += '-DHAVE_DL_ITERATE_PHDR'
-else
- # TODO: this is required for vulkan
+elif with_intel_vk
+ error('Intel "Anvil" Vulkan driver requires the dl_iterate_phdr function')
+elif with_dri_i965 and get_option('shader-cache')
+ error('Intel i965 GL driver requires dl_iterate_phdr when built with shader caching.')
endif
# Determine whether or not the rt library is needed for time functions