summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorSergii Romantsov <[email protected]>2019-02-22 11:23:08 +0200
committerEmil Velikov <[email protected]>2019-02-25 16:07:02 +0000
commitdcc48664197c7e44684ccfb970a4ae083974d145 (patch)
tree1e29935275b645686647714ea8bd141a556c2033 /meson.build
parentf6556ec7d126b31da37c08d7cb657250505e01a0 (diff)
d3d: meson: do not prefix user provided d3d-drivers-path
The user can select the location where there d3d drivers are installed by the d3d-drivers-path meson option. By default path will be $prefix/$libdir/d3d. Currently we add $prefix to the user provided path. Resulting in an incorrect or even missing path. Based on logic of Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=109698 CC: Kenneth Graunke <[email protected]> CC: Emil Velikov <[email protected]> Signed-off-by: Sergii Romantsov <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8cac9f676dd..50d2eec97ef 100644
--- a/meson.build
+++ b/meson.build
@@ -610,7 +610,7 @@ with_gallium_xa = _xa != 'false'
d3d_drivers_path = get_option('d3d-drivers-path')
if d3d_drivers_path == ''
- d3d_drivers_path = join_paths(get_option('libdir'), 'd3d')
+ d3d_drivers_path = join_paths(get_option('prefix'), get_option('libdir'), 'd3d')
endif
with_gallium_st_nine = get_option('gallium-nine')