summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorJon Turney <[email protected]>2017-11-13 10:13:39 +0000
committerJon Turney <[email protected]>2017-11-16 13:51:25 +0000
commit8ceccbf80dea7ac34cda68ec3117d80dd8922159 (patch)
treebfa42f9fabd7bc2629bf11a3a0e2be0b6897610b /meson.build
parentff018a3f555238efc060ff4dc9cf27c1a0830522 (diff)
meson: Don't define HAVE_PTHREAD only on linux
I'm not sure of the reason for this. I don't see anything like this in configure.ac In include/c11/threads.h the cases are: 1) building for Windows -> threads_win32.h 2) HAVE_PTHREAD -> threads_posix.h 3) Not supported on this platform So not defining HAVE_PTHREAD for anything not Windows just means we can't build at all. When we are building for Windows, I'm not sure if dependency('threads') would ever find anything, or defining HAVE_PTHREAD has any effect, but avoid defining it there, just in case. Signed-off-by: Jon Turney <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7fdc3c280e6..383ebb36662 100644
--- a/meson.build
+++ b/meson.build
@@ -668,7 +668,7 @@ endif
# TODO: some of these may be conditional
dep_zlib = dependency('zlib', version : '>= 1.2.3')
dep_thread = dependency('threads')
-if dep_thread.found() and host_machine.system() == 'linux'
+if dep_thread.found() and host_machine.system() != 'windows'
pre_args += '-DHAVE_PTHREAD'
endif
dep_elf = dependency('libelf', required : false)