summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-20 15:45:22 -0700
committerDylan Baker <[email protected]>2017-10-23 11:45:38 -0700
commit51558a1d6ca43b201362b3b64c751cfc93584346 (patch)
treef6c26a256f2e48919d0707d8b6e369362cad7dbd /meson.build
parentba85525fcec65e021304a7ecd21e8fd20ce39f2d (diff)
meson: build etnaviv driver + winsys
Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Christian Gmeiner <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 92b875b1a10..a21781f3b8c 100644
--- a/meson.build
+++ b/meson.build
@@ -97,6 +97,7 @@ with_gallium_nouveau = false
with_gallium_softpipe = false
with_gallium_vc4 = false
with_gallium_vc5 = false
+with_gallium_etnaviv = false
_drivers = get_option('gallium-drivers')
if _drivers != ''
_split = _drivers.split(',')
@@ -106,6 +107,7 @@ if _drivers != ''
with_gallium_softpipe = _split.contains('swrast')
with_gallium_vc4 = _split.contains('vc4')
with_gallium_vc5 = _split.contains('vc5')
+ with_gallium_etnaviv = _split.contains('etnaviv')
with_gallium = true
with_dri = true
endif
@@ -606,6 +608,7 @@ dep_m = cc.find_library('m', required : false)
dep_libdrm_amdgpu = []
dep_libdrm_radeon = []
dep_libdrm_nouveau = []
+dep_libdrm_etnaviv = []
if with_amd_vk or with_gallium_radeonsi
dep_libdrm_amdgpu = dependency('libdrm_amdgpu', version : '>= 2.4.85')
endif
@@ -615,6 +618,9 @@ endif
if with_gallium_nouveau
dep_libdrm_nouveau = dependency('libdrm_nouveau', version : '>= 2.4.66')
endif
+if with_gallium_etnaviv
+ dep_libdrm_etnaviv = dependency('libdrm_etnaviv', version : '>= 2.4.82')
+endif
llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit']
if with_amd_vk