summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorSergii Romantsov <[email protected]>2019-02-21 10:28:11 +0200
committerEmil Velikov <[email protected]>2019-02-25 16:07:02 +0000
commitf6556ec7d126b31da37c08d7cb657250505e01a0 (patch)
tree6a76930692eb7028e760aecf254909a677893cd5 /meson.build
parent30828f4646af0318337c5b8b6baf4868f05df667 (diff)
dri: meson: do not prefix user provided dri-drivers-path
The user can select the location where there dri drivers are installed by the dri-drivers-path meson option. By default path will be $prefix/$libdir/dri. Currently we add $prefix to the user provided path. Resulting in an incorrect or even missing path. v2: fixed dri_search_path by default, rebased to master v3: new commit-message (Emil Velikov), cc mesa-stable Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=109698 CC: Rafael Antognolli <[email protected]> CC: Dylan Baker <[email protected]> Cc: 18.3 19.0 <[email protected]> Fixes: 306914db92e1 (meson: Add dridriverdir variable to dri.pc.) Signed-off-by: Sergii Romantsov <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 44bc2f7c2a4..8cac9f676dd 100644
--- a/meson.build
+++ b/meson.build
@@ -61,11 +61,11 @@ endif
dri_drivers_path = get_option('dri-drivers-path')
if dri_drivers_path == ''
- dri_drivers_path = join_paths(get_option('libdir'), 'dri')
+ dri_drivers_path = join_paths(get_option('prefix'), get_option('libdir'), 'dri')
endif
dri_search_path = get_option('dri-search-path')
if dri_search_path == ''
- dri_search_path = join_paths(get_option('prefix'), dri_drivers_path)
+ dri_search_path = dri_drivers_path
endif
with_gles1 = get_option('gles1')