summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-06-07 10:58:06 -0700
committerDylan Baker <[email protected]>2018-06-13 10:06:25 -0700
commite26af221438f77d8b81f956a56bc9e520f28236a (patch)
tree580687370340de3068977160ce3232b6b70a98ca /meson.build
parent6eaa01368554b57081254ffd473a55199993b98d (diff)
meson: Add support for SPARC assembly
This was blindly copied from autotools and tested by a helpful gentoo user. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 16866d77ed3..c78d34098ff 100644
--- a/meson.build
+++ b/meson.build
@@ -896,6 +896,11 @@ if with_asm
with_asm_arch = 'aarch64'
pre_args += ['-DUSE_AARCH64_ASM']
endif
+ elif host_machine.cpu_family() == 'sparc64'
+ if system_has_kms_drm
+ with_asm_arch = 'sparc'
+ pre_args += ['-DUSE_SPARC_ASM']
+ endif
endif
endif