summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-09-04 14:42:07 -0700
committerDylan Baker <[email protected]>2018-09-05 10:32:51 -0700
commitd25a27ec56dd9a722a3b6073ec0b6daa7993b0d7 (patch)
tree46d8a24ad97261d03a7785178dfa66f571c299a3 /meson.build
parentaf104ad79984c96df846ad9ac8d10b0ba67c0a36 (diff)
meson: Print a message about why a libdrm version was selected
We require a single version of libdrm for all of our libdrm dependencies (core and driver), but the way this is structured can make the error message less than helpful, as one driver might be the one setting the libdrm requirement, while another might be the one that generates the version failure. This adds a simple message to the output announcing which libdrm module set the version, which might be more helpful. v2: - Use message suggested by Eric Engstrom Fixes: c445b1d56f47922206de55e557444aadb62e11f6 ("meson: Use the same version for all libdrm checks") Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7f6f128e0b2..f33c596e03f 100644
--- a/meson.build
+++ b/meson.build
@@ -1121,12 +1121,17 @@ endif
# Loop over the enables versions and get the highest libdrm requirement for all
# active drivers.
+_drm_blame = ''
foreach d : _libdrm_checks
ver = get_variable('_drm_@0@_ver'.format(d[0]))
if d[1] and ver.version_compare('>' + _drm_ver)
_drm_ver = ver
+ _drm_blame = d[0]
endif
endforeach
+if _drm_blame != ''
+ message('libdrm @0@ needed because @1@ has the highest requirement'.format(_drm_ver, _drm_blame))
+endif
# Then get each libdrm module
foreach d : _libdrm_checks