summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-06-28 14:34:18 +0100
committerEmil Velikov <[email protected]>2018-08-07 17:23:17 +0100
commitc077b74ee8187042ad3ad8001d94074e73e3e9ea (patch)
tree4c84e3d7fdfb7258539185cb004e53773ab33e51 /meson.build
parent54d844897fe0afea4b5ddf08565af49a8191d808 (diff)
meson: use dependency()+find_program() for wayland-scanner
Helps when the native wayland-scanner is located outside of PATH. Inspired by the xserver code ;-) Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index cbaee5ceb22..a155905312d 100644
--- a/meson.build
+++ b/meson.build
@@ -1275,7 +1275,8 @@ endif
# TODO: symbol mangling
if with_platform_wayland
- prog_wl_scanner = find_program('wayland-scanner')
+ dep_wl_scanner = dependency('wayland-scanner', native: true)
+ prog_wl_scanner = find_program(dep_wl_scanner.get_pkgconfig_variable('wayland_scanner'))
dep_wl_protocols = dependency('wayland-protocols', version : '>= 1.8')
dep_wayland_client = dependency('wayland-client', version : '>=1.11')
dep_wayland_server = dependency('wayland-server', version : '>=1.11')