summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2019-07-30 15:41:06 +0100
committerEric Engestrom <[email protected]>2019-07-30 23:21:42 +0100
commitbf8b5de6b9eae3e6fe3a56514ca984285b9b36c2 (patch)
treebdb829d50c5bb42530b9c0a31c7df765bc1c86e9 /meson.build
parent46a3ea06be389f94db69e7a2ba67033b59c8d333 (diff)
scons+meson: suppress spammy build warning on MacOS
Originally introduced in c7f36574506838274460 ("darwin: Suppress type conversion warnings for GLhandleARB") to fix Bugzilla #66346 [1], this workaround was never ported to Scons or Meson. [1] https://bugs.freedesktop.org/66346 Cc: [email protected] Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Jose Fonseca <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c9f96e7135d..7e8fee2ee2a 100644
--- a/meson.build
+++ b/meson.build
@@ -252,6 +252,7 @@ endif
if host_machine.system() == 'darwin'
with_dri_platform = 'apple'
+ pre_args += '-DBUILDING_MESA'
elif ['windows', 'cygwin'].contains(host_machine.system())
with_dri_platform = 'windows'
elif system_has_kms_drm