summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorBenjamin Gordon <[email protected]>2018-06-13 16:17:32 -0600
committerGurchetan Singh <[email protected]>2019-03-21 10:18:31 -0700
commitb30aad552cde507a70c6bf3bc2ce40ed69e0ecf2 (patch)
treea3b516755365b867863253b75accecc4fdae8899 /meson.build
parente426c3a6cb020d1b156415e20c6f53a7195f96cd (diff)
configure.ac/meson.build: Add options for library suffixes
When building the Chrome OS Android container, we need to build copies of mesa that don't conflict with the Android system-supplied libraries. This adds options to create suffixed versions of EGL and GLES libraries: libEGL.so -> libEGL${egl-lib-suffix}.so libGLESv1_CM.so -> libGLESv1_CM${gles-lib-suffix}.so libGLESv2.so -> libGLES${gles-lib-suffix}.so This is similar to what happens when --enable-libglvnd is specified, but without the side effects of linking against libglvnd. To avoid unexpected clashes with the suffixed appended by libglvnd, make it an error to specify both --enable-libglvnd and --with-egl-lib-suffix. Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7a536982da6..7b337755544 100644
--- a/meson.build
+++ b/meson.build
@@ -375,6 +375,9 @@ if with_glvnd
elif with_glx == 'disabled' and not with_egl
error('glvnd requires DRI based GLX and/or EGL')
endif
+ if get_option('egl-lib-suffix') != ''
+ error('''EGL lib suffix can't be used with libglvnd''')
+ endif
endif
if with_vulkan_icd_dir == ''