summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-11-01 10:24:10 -0700
committerEmil Velikov <[email protected]>2017-11-08 15:53:00 +0000
commit8a36f025f46011f0ca56924633e8f6d9f1c9aaaf (patch)
treeeac7b4189e20a9a12c9ce221e116ace76dd3f827 /meson.build
parent85a017230cacd0661570421c8e5b0619e512d33d (diff)
meson: Allow building glvnd with EGL and non-dri based GLX
Because meson mirrors the auototools logic, it needs the same changes to allow building glvnd based egl. v2: - change if to elif (Eric) Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Acked-by: Emil Velikov <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 44e062e01e9..cd706510226 100644
--- a/meson.build
+++ b/meson.build
@@ -231,8 +231,12 @@ if with_glx != 'disabled'
endif
with_glvnd = get_option('glvnd')
-if with_glvnd and with_glx != 'dri'
- message('glvnd requires dri based glx')
+if with_glvnd
+ if with_glx == 'xlib' or with_glx == 'gallium-xlib'
+ error('Cannot build glvnd support for GLX that is not DRI based.')
+ elif with_glx == 'disabled' and not with_egl
+ error('glvnd requires DRI based GLX and/or EGL')
+ endif
endif
# TODO: toggle for this