summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-12-04 10:06:08 -0800
committerDylan Baker <[email protected]>2018-12-18 09:20:53 -0800
commit7a90886921eb1d5d73b40aadd6fd3f340041bd26 (patch)
tree2f3b97cf407b732e218c295a8a9adb23a8abb93a /meson.build
parent8c77f4c76ddfe0b692b430b012b65f6981a53336 (diff)
meson: Add toggle for glx-direct
GNU Hurd needs to turn off glx-direct, rather than special case it, we'll just add a toggle. CC: 18.3 <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 8eb5c092454..57dd8b59cb4 100644
--- a/meson.build
+++ b/meson.build
@@ -51,6 +51,7 @@ with_valgrind = get_option('valgrind')
with_libunwind = get_option('libunwind')
with_asm = get_option('asm')
with_glx_read_only_text = get_option('glx-read-only-text')
+with_glx_direct = get_option('glx-direct')
with_osmesa = get_option('osmesa')
with_swr_arches = get_option('swr-arches')
with_tools = get_option('tools')
@@ -365,9 +366,6 @@ if with_glvnd
endif
endif
-# TODO: toggle for this
-with_glx_direct = true
-
if with_vulkan_icd_dir == ''
with_vulkan_icd_dir = join_paths(get_option('datadir'), 'vulkan/icd.d')
endif