summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorStefan Schake <[email protected]>2018-04-25 00:00:57 +0200
committerEric Anholt <[email protected]>2018-05-17 16:04:24 +0100
commit4fc0ebdff55419965919e4d6bf3c7f7f2759f7aa (patch)
treefc89197961c19334136146a202dcde660b97cb0e /meson.build
parent580d1f4c607bc6cd5bf24f9d303a502d6d9dcaec (diff)
broadcom/vc4: Bump libdrm requirement
Require a version of libdrm with syncobj support. v2: Don't require a libdrm_vc4, just bump core libdrm if vc4 enabled (by anholt) Signed-off-by: Stefan Schake <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b8ebda9cdc7..0f88ddfe8e7 100644
--- a/meson.build
+++ b/meson.build
@@ -1055,6 +1055,12 @@ _libdrm_checks = [
['freedreno', with_gallium_freedreno],
]
+# VC4 only needs core libdrm support of this version, not a libdrm_vc4
+# library.
+if with_gallium_vc4
+ _drm_ver = '2.4.89'
+endif
+
# Loop over the enables versions and get the highest libdrm requirement for all
# active drivers.
foreach d : _libdrm_checks