summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-10-11 16:00:04 +0100
committerEric Engestrom <[email protected]>2018-11-13 17:25:02 +0000
commit4fa2fb35245448f8b5d81fb5b37afec4f343f18a (patch)
tree8c2c00cfda195026e777789e91b6f9dba185e3e9 /meson.build
parent7df80de6e645ba8c20d97f5f2b1f6c12aa962e29 (diff)
meson: fix wayland-less builds
Those empty variables in the !wayland case are useless and running that meson.build with them breaks the build: [287/850] Generating wayland-drm-client-protocol.h with a custom command. FAILED: src/egl/wayland/wayland-drm/wayland-drm-client-protocol.h client-header ../src/egl/wayland/wayland-drm/wayland-drm.xml src/egl/wayland/wayland-drm/wayland-drm-client-protocol.h /bin/sh: client-header: command not found ninja: build stopped: subcommand failed. Fixes: d1992255bb29054fa5176 "meson: Add build Intel "anv" vulkan driver" Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Emil Velikov <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 0 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 58ff3ea9735..1b475877827 100644
--- a/meson.build
+++ b/meson.build
@@ -1318,13 +1318,6 @@ if with_platform_wayland
'linux-dmabuf', 'linux-dmabuf-unstable-v1.xml'
)
pre_args += ['-DHAVE_WAYLAND_PLATFORM', '-DWL_HIDE_DEPRECATED']
-else
- prog_wl_scanner = []
- wl_scanner_arg = ''
- dep_wl_protocols = null_dep
- dep_wayland_client = null_dep
- dep_wayland_server = null_dep
- wayland_dmabuf_xml = ''
endif
dep_x11 = null_dep