summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-10 15:25:07 -0700
committerDylan Baker <[email protected]>2017-10-16 16:32:43 -0700
commit3b209e9304b88ecad5c49694a98deb8f28f4c5f7 (patch)
tree30f5292633d490ec5845dc31c761e9a207235bb8 /meson.build
parent9e779e59b20ea9510801a4484613d33d8a8e4c3e (diff)
meson: Add switch for texture float
Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 02264aeed4e..54230a91ed5 100644
--- a/meson.build
+++ b/meson.build
@@ -37,6 +37,10 @@ with_vulkan_icd_dir = get_option('vulkan-icd-dir')
with_tests = get_option('build-tests')
with_valgrind = get_option('valgrind')
with_asm = get_option('asm')
+if get_option('texture-float')
+ pre_args += '-DTEXTURE_FLOAT_ENABLED'
+ message('WARNING: Floating-point texture enabled. Please consult docs/patents.txt and your lawyer before building mesa.')
+endif
# XXX: yeah, do these
with_appledri = false