summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorBas Nieuwenhuizen <[email protected]>2018-08-08 22:23:57 +0000
committerChia-I Wu <[email protected]>2019-03-11 10:01:15 -0700
commit26380b3a9f8fd513dc4da86798f3c15191914fc2 (patch)
tree1749fb5529155b2f5175a54bd1e011b4f9a73386 /meson.build
parentd086d16b8165244db53f20dbf60c921f4bb38f38 (diff)
turnip: Add driver skeleton (v2)
meson files have been updated, autotools and android still need updating. Only build tested. v2 (chadv): - Rebase onto master. - Fix build breakage in Python scripts. - Drop the WSI code. The internal WSI apis have changed recently, and will likely change again before the driver goes upstream. To avoid unnecessary rebase work, let's drop the WSI code and re-add it when we're ready to really use WSI. (olv, after rebase) do not enable freedreno by default on ARM
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2ccf5f2a4ca..8ec0a56ad30 100644
--- a/meson.build
+++ b/meson.build
@@ -203,6 +203,7 @@ endif
with_intel_vk = _vulkan_drivers.contains('intel')
with_amd_vk = _vulkan_drivers.contains('amd')
+with_freedreno_vk = _vulkan_drivers.contains('freedreno')
with_any_vk = _vulkan_drivers.length() != 0 and _vulkan_drivers != ['']
if with_dri_swrast and (with_gallium_softpipe or with_gallium_swr)